TARP Overview

1. OVERVIEW

Thermal Analysis Results Processor (TARP) is a Windows® based, post-processing program that interfaces with numerous commercial thermal solvers. The basic approach of TARP is to allow the user to define objects within the TARP environment, which are then used to create a Microsoft Excel® workbook containing the objects defined by the user.

The TARP main interface, shown below, is where all objects are created. From the main interface, the user defines the properties of the output workbook, specifies additional files to be included, creates DataSet, Plot, Table, Group, and Parameter objects, adds/removes data from the objects, and creates the resulting workbook. Once the session is defined, it can be saved to a session file for later modification or retrieval. The Make XL button is then used to generate the workbook.

Forward to Main Interface


Main Interface

2. Main Interface

The main interface for TARP is where the user defines the properties of, and objects to be included in, the output Excel® workbook. The user should first select any Workbook Properties as desired. Objects are then added to the session through the TARP Objects tree. Nodes for the current DataSet, as well as any defined Groups or Parameters, are displayed in the Working Node List. Filtering can be used to display only nodes meeting the specified criteria. From here, a subset of nodes can be easily selected from the Working Node List and added to objects in the TARP Objects tree. As objects are selected in the TARP Objects tree, the associated nodes are shown in the Nodes in Current Object listbox.

2.1 TARP Objects

The TARP Object tree is where the user adds TARP objects to the current session. Available TARP objects include:

ObjectType | HasProperties | HasNodes
DataSet | Yes | No
Plot | Yes | Yes
Table | Yes | Yes
Group | No | Yes
Parameter | No | Yes

To add an object, the user right clicks in the TARP Objects tree to bring up a Context menu, shown to the left. If the user selects a specific object type (e.g. Add DataSet), then that object type is added. If the user selects Add Object, then the new object type is based on the currently selected object in the TARP Objects tree (e.g. if a Plot is selected, then a new Plot is created). When adding a Parameter the parameter type must be further specified as described in the Parameters section. As objects are added to the tree, they are placed into the correct grouping (e.g. DataSet into DataSets, Plot into Plots, etc). One exception to this is the creation of Groups, since Groups may be nested up to three levels deep. If an existing Group is selected in the TARP Objects tree when a new group is created, the new Group is added as a child to the currently selected group. If an existing Group is not selected in the TARP Objects tree when a new group is created, then the new Group will be at the root level under Groups. A group cannot be created below the third level. If multiple objects are to be created at once (e.g. 5 Tables), the user should first toggle the Add Multiple option and then add the object. If this option is checked, then TARP prompts the user for the number of objects to create. Objects can also be deleted from the tree if no longer needed.

The names of each DataSet, Plot, and Table translate to sheet names in the resulting output workbook; therefore, these must each be unique. The names of Groups and Parameters translate to additional data points and must also be unique (but may duplicate sheet names). To rename an object from its default name, the user selects the object to rename, pauses for a second, and clicks the object again. At this point, the name is selected in a local textbox and is modifiable by the user. For DataSets, the name can also be changed by changing the XL Sheet field. DataSets, Plots, and Tables also have additional properties to fully define the object. These are accessed by double-clicking the object in the TARP Objects tree. The sheet name can also be changed on the properties form for each object.

2.2 Entering Filenames

When a DataSet or Additional File is selected in the TARP Objects tree, the Filename field is enabled for input, and the currently associated filename (if any) is displayed. Furthermore, for a DataSet, the Format and XL Sheet fields are enabled and display their respective data. Selecting the browse button [image] prompts the user for the filename to associate with the selected DataSet or Additional File. The selected file can also be viewed in a Text Editor (or Excel® for the output file) by selecting the preview button [image] .

If the object selected is a DataSet, TARP attempts to determine the format (e.g. SINDA85, ESATAN, etc.) based on a header found in the first lines of the file. If the determined file format (e.g. SINDA/G) matches the displayed format (e.g. SINDA/G-Q), then the Format field is not changed. If the determined format (e.g. SINDA/G) does not match the displayed format (SINDA85-Q), then the displayed format is updated with the assumption that the user wants to process temperatures (SINDA/G-T). The format can be changed after the file is selected. The XL Sheet field shows the name of the DataSet (usually defaults of Data1, Data2, Data3, etc.). The XL Sheet field (and also the DataSet name) can be automatically set to the basename of the selected file (e.g. Case1 for Case1.out) if the Sheet Names Same as Filenames preference is enabled, as long as no duplications occur (e.g. two DataSets with the same filename).

2.3 Using the Working Node List

Once the filename for a DataSet has been selected, the nodes contained in that file are loaded into the Working Node List. These nodes can be filtered by entering the desired range in the Node Filter. Only nodes meeting the user-specified criteria are then displayed in the Working Node List, allowing the user to display only a subset of nodes of interest. Values can be entered as either single nodes (SUB.100, 200) or ranges of nodes (SUB.1-100, 1-200). Multiple entries should be separated by commas (1-10, SUB.20). If no submodel is specified in a filter entry, then any nodes meeting the criteria is displayed, regardless of submodel (e.g. 1-10 would display INST.1 or SC.1). If a SINDA85 model is loaded, then a list of submodels from the file is stored in the Node Filter combo-box for quick filtering. Furthermore, all defined Groups and Parameters are always displayed at the start of the Working Node List, regardless of the filter criteria. The Working Node List is intended to be a frequently changing list as the user decides which nodes are needed for which objects and changes the list accordingly.

A user may also load a node selection file if desired. Clicking the Browse button to the right of the Node Filter [image] prompts the user for a .sel file. This file is processed and each line is one entry in a filter criteria string. The file name is then displayed in the Node Filter combo-box and the nodes in the Working Node List is filtered accordingly. To preview or modify this file, the user may select the preview button to the right of the Node Filter [image] .

2.4 Adding Nodes to TARP Objects

When the user has selected a collection of desired nodes in the Working Node List, they can then be added to a TARP object via two methods. The first is to select the desired nodes and right click to display the Context Menu shown to the left. From here, the user can add the selected nodes to the specified Object or the currently selected object. The second method is to select the desired nodes in the Working Node List, drag them from the Working Node List, and drop them on the desired object in the TARP Objects tree. Note that DataSets do not accept node inputs. Nodes can be added to Groups or Parameters; while nodes, Groups, and Parameters may all be added to Tables and Plots. If nodes are not needed for an object, they can be deleted from the Working Node List. Lastly, options exists to create groups directly from the submodels (if the output supports submodels) or load groups from an existing file. This is discussed further in the Groups section.

2.5 Working With Nodes in a TARP Object

Once nodes have been added to an object (or when the object is selected in the TARP Objects tree), the nodes contained in that object are displayed in the Nodes in Current Object listbox. For Plots, additional information is also shown in the Nodes in Current Object listbox for each entry, including the source DataSet for the series and the plot axis (Primary or Secondary). For a Difference Parameter, an additional “+” or “–” prefix is shown to indicate that one node is subtracted from the other. A Context Menu (accessed by a right click) allows the user to further manipulate the nodes in an object. All nodes can be quickly selected or deselected and removed from the object as desired.

Some features are also object specific. If the currently selected object in the TARP Objects tree is a Plot, then the user is able to change the source DataSet or the plotting axis for any series. If it is a Table, then the user can insert Table SubHeadings (see Table Output for an example). If the selected object is a Difference type parameter, then the order of the two nodes can be reversed. Each of the options beneath a blue line in the image are only available if the object type is of the appropriate type.

2.6 Saving and Loading Sessions

Once all the objects are fully defined in the TARP environment, the session can be saved for later use. Under the File menu, the user has options to Save, Open, Edit, or create a New session file. The session files are simple ASCII files that store all properties for every object defined. Further information can be found in the section on sessions. The four most recently opened or saved sessions are also displayed under the File menu.


Preferences

3. Preferences

A number of preferences to control the behavior of the main interface are accessible under the Tools menu. The General Tab allows the user to set the Text Editor to be used for previewing files. An option is also available for displaying full paths to filenames or simply the basename and extension. This can be useful when a file is nested many directories deep and the filename cannot be seen in the text box without scrolling. Debug modes also exist, which report numerous breakpoints in the code to indicate progress. This is intended to be used to help troubleshoot locations in the code where an exception may have occurred, without the need for a user to provide files to the software vendor for debugging purposes (e.g. proprietary models).

For DataSets, the Formats to Show frame has a listing of all supported output file formats. Only those that are checked are displayed in the Format field at the main interface and the DataSet properties form. For example, if a user only needs SINDA/G outputs, then all other formats could be removed from the display by unchecking all options except SINDA/G. Default units for DataSets can also be set and applied to all new DataSets. An option als exists to Compress Non-Varying Conductor Output. This can save significant space in the output workbook, as a constant conductor is only output once, instead of each timestep. Lastly, the Excel® SheetName can be automatically set to the base name of the file. This may not be available if the same filename is used for multiple datasets (e.g. Temp and Heat from same file).

As nodes are added to an object from the Working Node List, they can be automatically removed from the Working Node List when they are added to a Plot (or Table or Group). This can be helpful to see what nodes remain that have not yet been included on a Plot (or Table or Group). The default series characteristics, including line type, color, and weight and marker symbol, fore color, backcolor, size, shadow, and frequency are also displayed. While these cannot be changed here, it does provided a simple view of what values will be assigned to series as they are added to a plot. The values may be sset at a Plot Properties form.

Tables include an option for the creation of Dynamic Columns. This allows the user to define the source sheet and source parameter for each column of simple values by selecting the appropriate values from dropdown listboxes. For further information, see the Tables section.

Lastly, for groups, and option exist to either delete subgroups when a group is deleted or promote the subgroups up to the next level. Furthermore, nodes displayed in a group can be controlled to either display only the nodes defined in the group, or to include all nodes contained in child groups of the selected group.


Workbook Properties

4. Workbook Properties

Properties for the workbook are selected from the options under the WorkBook Properties branch in the TARP Objects tree. Selected options are indicated by an (x). Clicking the option toggles the value between selected and not selected. Available workbook properties include: Include Node Descriptions, HeatMap, Compare HeatMap, and Update Existing Data.

4.1 Including Node Descriptions

The Include Node Descriptions option requires either the thermal model input file (for SINDA85, SINDA/G, and TAK2000) or a PRNDTB call for ESATAN output. For thermal model input, two types of comments are processed: in line comments, and block comments. For the following NODE DATA section, the in-line comments are what appear after the comment character ($), and the block comments are what appear before the block of nodes. Therefore, “Panel Nodes” is the Block description for Node 10, and the in-line comment is “Upper Panel”. For ESATAN, a PRNDTB is expected prior to any other calls with the ‘L’ zent included. For TMG, no option currently exists to associate nodes with descriptions.

C    Panel Nodes

C

       10, 10.0, -1.0   $ Upper Panel

       20, 10.0, -1.0   $ Lower Panel

The outputs from this data are stored on the NodeInfo sheet created in the output workbook. The first two columns (A and B) are reserved for the Block Description and the Node Description, while the third column displays the node number. This range of data in Excel® is subsequently used by Tables and HeatMaps to display the Node Description along with the node number. Should the user wish to change this data, it need only be changed on the NodeInfo worksheet to propagate to all other references.

4.2 Updating Existing Data

The Update Existing Data option allows the user to update only the data contained in DataSets. It does not generate any of the other objects specified in the session. Upon specifying an Excel Output File with this option enabled, the specified workbook is scanned to determine the names of all existing sheets. If a new worksheet name is specified, then this sheet will be added to the workbook and does include the Minimum, Average, and Maximum formulas as well as the Group definitions. If the specified worksheet name already exists, then only the data is updated; the Group, Minimum, Average, and Maximum formulas are not updated. If plots or tables exist in the output workbook, then the data needs to be in exactly the same order and have the same number of timesteps to ensure that all Plots/Table formulas still reference the correct rows and columns.

4.3 Creating HeatMaps

The HeatMap and Compare HeatMap options specify that a specialized, interactive workbook is created to investigate heat flow between nodes and/or groups of nodes. This workbook type requires Temperature, Heat, and Conductor data for each output timestep. Upon selecting the HeatMap option, all existing DataSets are deleted and three pre-defined DataSets are created: Temp, Heat, and Cond. Selecting the Compare HeatMap option removes all existing DataSets and creates 6 pre-defined DataSets: TempA, HeatA, CondA, TempB, HeatB, and CondB. Additional DataSets may not be created or removed when HeatMap options are enabled.

Certain options are only available under certain conditions. For example, selecting the HeatMap does not allow the user to also select Compare HeatMap. Furthermore, selecting either HeatMap option also enables the Include Node Descriptions option, as the input file must be processed for Node Descriptions used in the HeatMap output as well as the node pairs for each conductor (for SINDA85, SINDA/G, and TAK2000). For ESATAN output, the node pairs and node descriptions are available in the output file, therefore, the input file is not needed.


Additional Files

5. Additional Files

Additional files may also be needed to create the workbook. The Excel Output filename, Thermal Model input file(s), user Limit File, and Unit Conversion files may all be specified and used in the creation of the final workbook.

5.1 Excel Output File

The ExcelOutputFile specifies the path to the output workbook to be generated by TARP. By default, this is left blank. If the value is blank and a file for the first DataSet is selected, then the ExcelOutputFile is updated to have the same base name and path as the filename specified for the first DataSet. If the user then selects another file for the first DataSet, the ExcelOutputFile will not be changed unless they have made it blank prior to the second file selection. Therefore, some care should be taken when continuously working in the same session. It is recommended that if a user wishes to use this feature with multiple file selections for the first DataSet in the same session that they first select New from the File menu to start a new session and allow TARP to set the ExcelOutputFile. The user can over-write this default if a different output filename is desired.

5.2 Input Files

The InputFile(s) are used for two separate sub-tasks. If the user has enabled the Include Node Descriptions workbook property, then the input file is used to extract the node descriptions. Furthermore, if the user has specified the HeatMap or CompareHeatMap workbook property, then the thermal model input file is necessary to extract the node pairings for each conductor for SINDA85, SINDA/G and TAK2000.

5.3 Limit File

The LimitFile is a user-created file that defines limits to be applied to nodes in a comma-separated format. The first line of this file should include the word Node followed by the limit names desired by the user. Once a LimitFile is specified, the limit names, as defined on the first row, are available for inclusion in any table. A sample format is shown below.

Node, Red High, Yellow High, Yellow Low, Red Low

INST.1, 45, 40, -30, -35

INST.12, 40, 30, -30, -40

...

5.4 Unit Conversion File

The UnitConversionFile is another user-defined file that specifies the necessary coefficients to convert from one set of units to another for DataSets. The following Unit conversion coefficients are included; should the user need units not supplied, this file can be modified to include new unit sets. However, it is advised to include unit conversions for all other units available for the Unit Type. (i.e. if the user adds a new heat unit, include conversion to all other existing heat units)

Unit Type

From Unit

To Unit

Unit Type

From Unit

To Unit

Time

s

min

Time

hr

s

Time

s

hr

Time

hr

min

Time

s

day

Time

hr

day

Time

min

s

Time

day

s

Time

min

hr

Time

day

min

Time

min

day

Time

day

Hr

Temperature

°C

K

Temperature

°F

°C

Temperature

°C

°F

Temperature

°F

K

Temperature

°C

R

Temperature

°F

R

Temperature

K

°C

Temperature

R

°C

Temperature

K

°F

Temperature

R

°F

Temperature

K

R

Temperature

R

K

Heat

W

J/min

Heat

BTU/hr

W

Heat

W

BTU/hr

Heat

BTU/hr

J/min

Heat

W

BTU/min

Heat

BTU/hr

BTU/min

Heat

J/min

W

Heat

BTU/min

W

Heat

J/min

BTU/hr

Heat

BTU/min

J/min

Heat

J/min

BTU/min

Heat

BTU/min

BTU/hr

Lin Cond

W/K

J/min/K

Lin Cond

BTU/hr/R

W/K

Lin Cond

W/K

BTU/hr/R

Lin Cond

BTU/hr/R

J/min/K

Lin Cond

W/K

BTU/min/R

Lin Cond

BTU/hr/R

BTU/min/R

Lin Cond

J/min/K

W/K

Lin Cond

BTU/min/R

W/K

Lin Cond

J/min/K

BTU/hr/R

Lin Cond

BTU/min/R

J/min/K

Lin Cond

J/min/K

BTU/min/R

Lin Cond

BTU/min/R

BTU/hr/R

Rad Cond

cm2

m2

Rad Cond

in2

cm2

Rad Cond

cm2

ft2

Rad Cond

in2

m2

Rad Cond

cm2

in2

Rad Cond

in2

ft2

Rad Cond

m2

cm2

Rad Cond

ft2

cm2

Rad Cond

m2

ft2

Rad Cond

ft2

m2

Rad Cond

m2

in2

Rad Cond

ft2

in2

Capacitance

J/K

W min/K

Capacitance

BTU sec/min/R

J/K

Capacitance

J/K

BTU sec/min/R

Capacitance

BTU sec/min/R

W min/K

Capacitance

J/K

BTU/R

Capacitance

BTU sec/min/R

BTU/R

Capacitance

W min/K

J/K

Capacitance

BTU/R

J/K

Capacitance

W min/K

BTU sec/min/R

Capacitance

BTU/R

W min/K

Capacitance

W min/K

BTU/R

Capacitance

BTU/R

BTU sec/min/R


DataSets

6. DataSets

DataSets are Excel® worksheets that contain the raw data from the thermal model output file. The user has options to specify the Source File, Format, Parameter, and worksheet name. Further options are also available under the DataSet properties form, including: unit conversion, transposing of the output, selecting nodes for output, selecting timesteps for output, inclusion of additional output points (e.g. Minimum, Maximum, etc.) and the definition of the last cycle for cyclical output.

6.1 Supported Formats

TARP can process a number of commercial thermal solver outputs based on the common outputs each is capable of providing including SINDA, ESATAN, TMG, and TAK2000. It also includes the ability to process thermal radiation solver output. The following formats and parameters are supported:

Format | Parameters
SINDA85 & SINDA/FLUINT | T, Q, G, C*
SINDA/G | T, Q, G, C, F
ESATAN (PRNDBL) | T, Q, QS, QA, QE, QI, QR, G, GL, GR, C*
ESATAN (PRNDTB) | T, Q, QS, QA, QE, QI, QR
TMG | T, Q
TAK2000 | T, Q, G, C
TSS | Q, G*
ThermalDesktop | Q*, G*
Comma, Space, or Tab Delimited | T, Q, G

* Planned Additions

6.2 Converting Units

Unit conversion is based on the conversion coefficients provided in the UnitConversionFile.csv specified under Additional Files. Only units applicable to the current parameter are displayed. The units available are based on those contained in the UnitConversionFile, as well as the conversion coefficients used in the resulting formulas. Both Linear and Radiative conductors can be converted. For heat flux from a Thermal Radiation output file (e.g. ThermalDesktop, TSS), the area component can also be converted independent of the energy term.

6.3 Data Limitations

By default, TARP outputs the data with each row representing a single node, group, or parameter. Correspondingly, each column represents a timestep. A limit of 256 columns and 65536 rows exists for any single worksheet. Since the first 3 columns are used for Major, Minor, and SubGroup definitions, and the fourth column is reserved for the node number, a maximum of 252 columns are available for output timesteps. This number may also be further reduced by the inclusion of up to 6 additional parameters: Minimum, Average, Maximum, Time Min, Time Max, and Delta. In general, 246 columns should be sufficient for the majority of model outputs. If the number of rows exceeds what can fit on one sheet, then additional sheets are created with the same basename and an incremental counter (e.g. Cond2, Cond3, etc.). Note that if data is written to subsequent sheets, any formulas referencing the DataSet (in Plots, Tables, Groups, etc.) do not recognize that data has been written to another sheet.

In some instances, it may be necessary to include more timesteps than allowed on a single sheet. For these cases, the output can be transposed, with each column representing a node/group/ parameter and each row representing a timestep. The user is then limited to 255 nodes/groups/ parameters. Should it be necessary to include more data than can fit onto a single worksheet, it is suggested to create multiple datasets with the required data.

6.4 Filtering Nodes and Timesteps

Selected nodes can be output using one of two methods. Selecting …Referenced Nodes outputs only nodes that are used in a Plot, Table, Group, or Parameter. All other nodes are not output. The second method is to specify nodes …Meeting Filter Criteria. In this case, all nodes are processed, but only those meeting the specified filter criteria are output. The filter criteria is based on the same rules for the Node Filter at the main interface. Filter entries can be entered as either single nodes (SUB.100, 200) or ranges of nodes (SUB.1-100, 1-200). Multiple entries should be separated by commas (1-10, SUB.20). If no submodel is specified in a filter entry, then any nodes meeting the criteria are displayed, regardless of submodel (e.g. 1-10 would display INST.1 or SC.1).

Specific timesteps can also be selected for output by selecting the desired timesteps in the Output Timesteps listbox. A user can output repeating patterns of timesteps using the Include/Skip values. An Include of 1 and a Skip of 1 would output every other timestep; an Include of 1 and a Skip of 4 would output every fifth timestep.

6.5 Defining the Last Cycle

The Last Cycle can be used for cyclical output that repeats a time period (e.g. 0-6000, 0-6000, 0-6000…) to define the time range for plotting and over which to compute the Additional Parameters. By default, TARP starts at the last timestep and checks if the preceding timestep is smaller. If so, it continues tracing back until a timestep value greater than the current location or steady state results are found. The user can over-ride this default by specifying their own range as the last cycle. Once this is set, the user can opt to include additional output such as the Maximum, Average, or Minimum over this range, the timesteps where these occur, or the Delta (Maximum-Minimum) over this range.

6.6 DataSet Output

A sample DataSet output is shown above. Cell D2 (or B4 if the data is transposed) includes a comment that provides traceability for the output, indicated by a small red triangle in the upper right hand corner of the cell. This comment includes: the source file name, format, parameter, path, and size, as well as original and converted units, node filter criteria, and an indication if timesteps were filtered. Any converted data is displayed as the result of a formula. Therefore, the original raw data value is preserved in the formula (e.g. “=93.075 * 0.5555556 + -17.77778”); the conversion can be removed by performing a search and replace on the entire sheet for the conversion formula. Hint: to avoid the * being interpreted as a wildcard, replace “0.5555556 + -17.77778” with “1”.

In addition to the raw data, groups and parameters are also added to the data. The Group definitions for each node are shown in Column A (MajorGroup), Column B (MinorGroup), and Column C (SubGroup). The values are determined using MATCH and INDEX Excel® functions referencing the NodeInfo sheet. Therefore, changes in Group definitions made on the NodeInfo sheet are automatically updated on all DataSet sheets. The computed values for each group are appended to the end of the node data block, with Group values representing the total heatload or the average temperature. These values are defined using SUMIF and COUNTIF formulas in Excel®. Groups defined at the Major level appear exactly as named. Groups at the Minor level are preceded by 3 spaces, and groups at the Sub level are preceded by 6 spaces. If nodes exist in the same group name at multiple levels (e.g. nodes defined in Minor group that are also included in Sub group of the same name), then the group name may appear more than once but with different spacing.


Plots

7. Plots

Plots are graphical representations of data as a function of time. Each plot consists of a Title, an X and a Y axis (and maybe a secondary Y axis), and a collection of data series. Each series is represented by one line on the plot, which can have varying Line properties (LineType, Color, Weight) and Marker properties (Symbol, ForeColor, BackColor, Size, Frequency, and Shadow). The Plot properties form is shown below.

7.1 Axis Properties

The axes properties can be defined by the user including axis Maximum and Minimum, and Major and Minor Divisions. The Default Max or Default Min options allow Excel® to set the values. By default, both Major and Minor gridlines are displayed, unless the user sets the Major Division equal to the Minor Division. The axis titles and units are based on the source DataSets found on the Plot. If a DataSet is for Temperatures with units of °C, then the axis title reflects this. If two types of units are found on one axis, then both are indicated. A secondary axis is also available, but is only enabled if any series on the plot is set to the secondary axis. This is most useful for plotting two different units together on the same plot (e.g. Temperature and Heat to verify heater behavior). The axes properties can also be applied to all plots to ensure consistency across multiple plots.

7.2 Series Properties

The user also has control over individual series properties. Three types of series characteristics are available for modification: Data, Line, and Marker. Any changes made in the Series Properties frame are applied to all nodes selected in the Series List, allowing for multiple series to be changed at once. The Data characteristics include the Source DataSet and the axis on which to plot the series. Line characteristics include Line Style, Color, and Weight. The marker characteristics include Symbol, Fore Color, Back Color, Size, Shadow and Frequency. Marker frequency is the only option available through TARP that is not readily changeable in Excel®. This option allows a user to place a marker every so many data points for series that are very dense and would have too many markers near each other to be able to distinguish the marker symbol. The table below shows the options available for each characteristic.

Style | Color | Weight | Symbol
Solid | Too numerous to list | Hairline | Square
Dashed | 56 Available | Thin | Diamond
Dotted |  | Medium | Triangle
Dash Dot |  | Thick | X *
Dash Dot Dot |  |  | Star *
Medium Density |  |  | Dot *
High Density |  |  | Dash *
Low Density |  |  | Circle
 |  |  | Plus *

* Indicates “Non Fillable” Marker

Certain options are available to help relate line and marker colors. The first option, Marker has same Fore Color as Line, automatically sets the marker Fore Color when the Line Color is changed. Furthermore, the Marker has same Back Color as Fore Color, sets the marker back color when the fore color is changed. The Set BackColor to None for Non-Fillable Markers option automatically sets the Back Color to None for X, Star, Dot, Dash, and Plus type markers. Lastly, the Apply Size/Freq changes to all Series option applies the Size or Frequency to all series when either of these options is changed.

Similar to axes properties, series properties can also be applied to all other plots to ensure consistency. However, since different plots can have different numbers of series, some care must be taken when using this feature. Assuming that Plot1 has 3 series and Plot2 has 7 series, applying series properties while on Plot1, would only affect the first 3 series on Plot2. Conversely, applying series properties on Plot2 would affect all 3 series on Plot1. Therefore, use of this feature is recommended when the plot being modified has the largest number of series.

7.3 Plot Output

A sample Plot output is shown above. The units and data type (e.g. Temp) are determined based on the DataSets for the series on the plot. The legend is shown at the top of the plot. Major and Minor gridlines are also shown on the example plot. For this example, the Last Cycle Definition begins just before 3600 seconds and ends at 6000 seconds. The user has full control over the plot within Excel® and can modify any of the properties associated with the plot or its series after the workbook is created.


Tables

8. Tables

Tables display nodal information at a static point in time. Tables can display Minimum, Average, or Maximum values, Steady-State data or any other timestep, as well as Limits from the specified LimitFile. Each row in the table represents a single node or group. Each column in the table displays the values for the parameter requested by the user. Conditional formatting can be applied to highlight nodes that exceed a limit condition or are within a specified margin of a limit. The user also has a number of formatting options available to control the table display. The Table properties form is shown below.

8.1 Defining the Operation and Source Sheet(s)

To begin, a user must select all the defining characteristics for a column. These include: the operation (e.g. Value, Difference), the source sheet(s), the parameter(s) to tabulate, and additional information if needed (e.g. Timestep, Limit Name). Four Operations are available: Value, Difference, Min of Sheets, and Max of Sheets. Value is a single datapoint from a single source DataSet. Difference allows a user to tabulate the difference between two points. This could be used to display a maximum change (Max-Min), a margin (Max-Limit), or the change between two orbital points (Timestep 35 – Timestep 21). Min of Sheets and Max of Sheets returns the worst case value from a collection of sheets. This can be used to display the maximum value from a selection of multiple cases (i.e. sheets). Once the Operation is selected, certain fields are enabled/disabled. For example, if a Difference operation is selected, then the Sheet 2 and Parameter 2 listboxes are enabled. Next, the user selects the source sheet (or sheets for Min of Sheets or Max of Sheets) from the Sheet 1 listbox. If a Difference operation is selected, then the user also selects the source sheet for Sheet 2.

8.2 Defining the Parameter and adding columns to the Table

After the Operation and Source sheets are defined, the Parameter is then selected. Six types of Parameters can be displayed: Min, Avg, Max, SS, Timestep, and Limit. Min, Avg, and Max parameters are only available if the user selected these values for the selected source DataSet. The SS parameter is only available if steady-state output was detected in the selected DataSet. Limits are only available if the user has defined a LimitFile under the AdditionalFiles section at the main interface. For Timesteps and Limits, the user must further select the particular occurrence to tabulate; available Limits or Timesteps are displayed in the listbox to the right of the Parameter listbox.

If Timesteps is selected as the Parameter, then a list of all output timesteps are displayed in the TimeSteps listbox. The user then selects one timestep to tabulate in the resulting table column. If Limit is selected as the Parameter, the user then selects the Limit Name from the Limits listbox. Limit Names are defined by the first row in the LimitFile specified by the user. Once all defining characteristics are set, the user then adds a column to the table using the Add to Table button. Alternatively, once all the necessary values are specified, a double click in the Sheet, Parameter, Limit, or Timestep listbox also adds the column to the Table.

8.3 Table Preview

A table preview is displayed under the Conditional Formatting Options frame. The first column shows the nodes in the table as added at the main interface. Each column added to the table is also displayed. Two fixed rows are reserved to display the Source Sheet and Parameter. In addition, if any limit has been added to the table, three additional fixed rows are reserved to display any applied conditional formatting. The user can delete columns in the table preview by selecting the column to delete and pressing the delete key. The order of the columns can also be adjusted in the table preview by selecting a column and dragging it to its new position using the right mouse button. If the column width is not sufficient to display the properties of a column, the column width can be changed by dragging its right edge. The cursor changes to a left-and-right arrow [image] as the user moves over the column edge with the mouse in the fixed rows portion of the display. When this occurs, the column can be resized. Note that the column size has no effect on the table output. The user can resize columns within Excel® if needed.

8.4 Applying Conditional Formatting

Conditional formatting is available once any limit has been added to the table. If limits are defined in the table, controls in the Conditional Formatting Options frame are enabled. A maximum of three conditions can be applied. However, if Condition 1 is satisfied, then Conditions 2 and 3 are not evaluated. The same applies for Condition 3 if Condition 2 is satisfied. Therefore, the user should take care and assign conditions in an order consistent with this behavior. Condition 3 can only be defined after Condition 2 is fully defined; Condition 2 can only be defined after Condition 1 has been fully defined.

Each condition consists of 5 basic parts: Condition, LimitName, Margin, Text Color, and Back Color. Condition is one of the following types: >, >=, <=, and <. LimitName is based on the limit selected by the user from the drop-down box. Therefore, the logic for Conditional Formatting is as follows: “IF value [< | <= | >= | >] LimitName ± Margin THEN APPLY Text Color, Back Color”. This can be used to highlight values that have violated a limit. Use of the margin can highlight values that are close to a limit. So, “>=LowLimit+5=3;0” would make the text red (color index 3) and the background the default color (color index 0) for values that were within 5 of the LowLimit. Note, that in general, the three Conditions are intended to be used as follows: Condition 1-Red Limit Violation, Condition 2-Yellow Limit Violation, Condition 3-Within specified Margin of Yellow Limit. Since a red limit is the most severe, values violating Condition 1 would not check Conditions 2 or 3.

8.5 Table Formatting Options

A number of formatting options are available to the user to control the appearance of the table. The DataFormat can be changed to display more decimal places in the output (up to 6). Both standard numbers (0.0) and scientific notation (0.0E+00) are available. The user is also able to change this on the resulting Excel® worksheet. For tables that span multiple sheets when printing, the user can opt to Repeat Header on Each Page. This displays the first two rows on each printed page. Otherwise, the first two rows are shown only on the first page. The Sheets on Top/Params on Bot is the means by which data is grouped together. One way is for the user to group similar Parameters (e.g. Min) together for multiple cases (Case 1, Case 2, etc.). A second way that the data may be grouped is to keep the cases together, and display varying parameters. The two table headers below best illustrate the two methods. The user can also Automatically Format Borders, which places thin gridlines around all the data and thick gridlines around sections with common Sheets or Parameters. In the headers below, the top sample would have thick gridlines around Case 1 and Case 2; the bottom sample would have thick gridlines around Min, Avg, and Max. Lastly, the user can make the font bold for values satisfying conditional formats by selecting Conditional Formats are Bold.

Case 1 |  |  | Case 2
Min | Avg | Max | Min | Avg | Max

Sheets on Top/Params on Bot = True

Min |  | Avg |  | Max
Case 1 | Case 2 | Case 1 | Case 2 | Case 1 | Case 2

Sheets on Top/Params on Bot = False

8.6 Table Output

A sample of Table output is shown above, including Table SubHeadings for Side Panles, Bottom Panel, and Top Panel. For this table, the node descriptions are included as well as limits and conditional formatting. The data shows 4 violations of the HighLimit, indicated by a red Back Color and white Text Color. It also shows 4 other nodes that are within 5° of the HighLimit, indicated by the red Text Color.

If the user has selected the Enable Dynamic Columns option under the Preferences form, then the table is shifted down by three rows. The first row includes a DynamicSheet label. This allows the user to select the Source DataSet for the column. Once this is selected, the user may then select the DynamicParameter, which is based on all columns on the selected DynamicSheet. These options allow the user to actually change the data that is displayed in the table without having to change the formulas. Note that changing DataSet sheet names in Excel® are not be updated in the DynamicSheets drop-down boxes.


Groups

9. Groups

Groups are used to simplify larger models. Groups return the average Temperature of, or total Heat Load on, all nodes contained in the group and all of its child groups. As a group is added to the session, it is displayed in the Working Node List at the main interface and is treated as if it were any other node in the model that can be added to a Table or Plot. Nodes are added to a group in the same manner as for Plots and Tables (see Adding Nodes to TARP Objects). However, a group may not be added to another Group or a Parameter in this manner, only nodes.

If a group is selected in the TARP Objects tree when a new group is created, the new group is a child group of the selected group; this is how multi-level groups are created in TARP. Groups may be nested up to three levels deep (Major, Minor, and Sub). These levels are intended to represent an Instrument:Region:Component hierarchy. In the group hierarchy tree to the left, the Panels group is a MajorGroup, with Outer and Inner child groups. Furthermore, the Outer MinorGroup has OuterSides, OuterTop, and OuterBot as child groups at the SubGroup level.

A node can only be defined in one group, but based on parent-child relations is included in up to three groups (one at each level). If a node is defined in a MinorGroup, then it is also included in its parent group as well as a SubGroup with the same name. The table on the left shows nodes 1 through 6, the group name where the nodes are defined, and group names at the Major, Minor, and Sub Group levels for the Panels:Outer:OuterSides path. The table on the right shows the resulting groups that are created by TARP for each level.

Node

Defined In

Major

Minor

Sub

Group

Level

Contains Nodes

1

OuterSides

Panels

Outer

OuterSides

Panels

Major

1,2,3,4,5,6

2

OuterSides

Panels

Outer

OuterSides

Panels

Minor

5,6

3

Outer

Panels

Outer

Outer

Outer

Minor

1,2,3,4

4

Outer

Panels

Outer

Outer

Panels

Sub

5,6

5

Panels

Panels

Panels

Panels

Outer

Sub

3,4

6

Panels

Panels

Panels

Panels

OuterSides

Sub

1,2

9.1 Fast creation of Groups, Promoting, and Demoting

For output with submodels (i.e. SINDA85 or SINDA/FLUINT), an option exists to create Major groups based on the submodels found in the output. A user can also load existing groups from a file. Nodes that are defined in a group can be demoted into a new child group or any existing child groups. Similarly, nodes in an existing group can be promoted into their parent group. These options cannot be applied to nodes that are displayed in a group because they are contained in a child of that group.

9.2 Group Output

A sample of Group output on a DataSet sheet is shown above. The actual group definitions themselves (Node-Group relations) are stored on the NodeInfo sheet. The values on the NodeInfo sheet are used in lookup formulas to define the groups for each node on the DataSet sheet. The Group assigned to each node is shown at all three levels in Column 1 (MajorGroup), Column 2 (MinorGroup), and Column 3 (SubGroup) using MATCH and INDEX commands.

Recall that nodes are defined in only one group, but can be included in up to three groups based on Parent-Child relationships. Therefore, all group possibilities (Names/Levels) are output at the end of the node data block. Group names at the MinorGroup level are preceded by 3 spaces, and group names at the SubGroup level are preceded by 6 spaces. A group name may be shown more than once, but at different levels. For example, nodes defined in a MajorGroup are also included in a MinorGroup and SubGroup with the same name (as in the Space group above). Some group names may only exist at one level, where all the nodes included in the group are defined in child groups. Therefore, the parent group would only exist at one level, as in the Panels MajorGroup above; for the Panels MajorGroup, nodes are included in child groups at the SubGroup level (OuterSides, OuterTop, etc.). The level for each group name is indicated in Column 3 beside the group name. This preservation of nodes at all three levels is necessary for ensuring that all nodes in a group are represented in HeatMaps, regardless of what level they are defined in. Groups that are plotted or tabulated are based on the first occurrence. For example, if the user requested the Space group above, then the Major level Space group would be displayed.

Formulas using SUMIF and COUNTIF are used to compute the average temperature and total heat load for each group. Any changes made to group definitions at the NodeInfo sheet propagate through to the group values via the formulas.


Parameters

10. Parameters

Parameters return the result of a predefined formula applied to nodes contained in the Parameter. Five parameter types are supported: Difference, Min of Nodes, Max of Nodes, Min of Group, and Max of Group. The Difference parameter expects two nodes and returns the difference between them (Node2 – Node1). The Min/Max of Nodes returns the minimum and maximum value found in a group of nodes respectively. The Min/Max of Group returns the Minimum and Maximum of nodes contained in the specified group. Each parameter created is available to be included in a Table or Plot.

10.1 Parameter Output

A sample of Parameter output on a DataSet sheet is shown above. The parameter name is shown in Column D. Column C contains a string value that defines the parameter type and the inputs to the parameter. If the parameter type is “Difference”, then native Excel® functions are used; for all other parameter types, a specialized VBA macro is called to compute the value for the parameter type.


HeatMaps

11. HeatMaps

HeatMaps are the most powerful feature available in TARP. HeatMaps are specialized workbooks with embedded VBA macros for computing and displaying heat flows within a model. Therefore, it is necessary to enable macros in Excel®. If macros have been automatically disabled, a user may need to manually enable them under Tools-Macro-Security in Excel® and select the Medium option. A HeatMap workbook is capable of displaying heat flow between two nodes, between two groups, from a group to nodes and from a node to groups. With 3 levels of grouping (plus an additional DynamicGroup option available only through HeatMaps) a variety of heat flow paths can easily be investigated. A sample workbook for a node-to-node HeatMap is shown below.

11.1 Creating the HeatMap

To create a HeatMap workbook, the HeatMap option must first be selected under the WorkBook Properties at the Main Interface. This automatically creates three DataSets: Temp (Temperatures), Heat (Heat Loads), and Cond (Conductances). Therefore, it is required that each time output is made from the model it must include Temperatures, Heat Loads, and Conductances. Failure to do this can result in Temperatures from one timestep being used with Heat Loads from another, as HeatMaps assume that each column on the three DataSet sheets represents the same timestep. If too much data is encountered (in particular for the conductances), then the additional data “spills over” onto sequentially numbered sheets (e.g. Cond2, Cond3, etc.). While there is no technical limit on the number of sheets, too large a workbook may fail to open on a user’s system. The size of a workbook that can be opened is dictated by a number of factors, including available memory.

Enabling a HeatMap also enables the Include Node Descriptions option, and therefore requires the user to specify the InputFile (for SINDA and TAK outputs). This InputFile is used to extract the node pairs for each conductor number. For ESABLK outputs, the node pairs and descriptions are included in the output file. The node pairs and conductor numbers are written to the Lin and Rad sheets for linear conductors and radiative conductors respectively. For SINDA models, the HeatMaps do not make any associations between which submodels are built and which are not. Therefore, errors can occur if the user does not build all the submodels, since a conductor may exist on the Lin/Rad sheets but not on the Cond sheets. If this is the case, the user is advised to manually remove the conductors not built in the solution from the Lin/Rad sheets and run the ReCalculateAll macro.

11.2 Controlling the HeatMap Output

All cells requiring input by the user are highlighted in red. When the workbook is initially opened, default values for Sigma and Toffset are entered. The user should first set these to the appropriate values for their model. Next, the user should select the timestep of interest in the Time drop-down box. At this point, the macros begin calculating the heat flow through each conductor and store the group-to-group and node-to-group heat flow components. When the user specifies a value for Node i, all values connected to Node i are displayed. Node i can be a group or a node; specifying a group results in Group-to-XXX heat flows. Specifying a node results in Node-to-XXX heat flows. Similarly, the Heat To parameter can be changed to Node, MajorGroup, MinorGroup, SubGroup, or DynGroup. Setting the Heat to to node results in XXX-to-Node heat flows. Therefore, the user has a number of options available for displaying heat flows based on the Node i and Heat to values. For example, if a group is specified as Node i and the Heat to is set to MinorGroup, then the heat flows displayed are Group-to-Group at the MinorGroup level. Any nodes not included in a group are displayed in the MISC group by default. This preserves energy balances throughout the model. Double clicking a Node j value replaces Node i with the Node j value selected and repopulates the HeatMap.

The output data displayed includes the node j description, node/group j, conductor type, conductance value, temperature of node/group j, and heat flow to each node/group j connected to node/group i. All linear conductors are grouped together as are all radiative conductors. The left hand side sorts the data from the largest quantity of heat leaving node/group i (negative heat) to the largest amount of heat entering node/group i (positive). The right hand side reverses this order. The user can control how many decimal places are shown for temperature and heat flow using the formats available in the Format field. Furthermore, the user can opt to only display heat flows above the cutoff specified in Min Heat. In the top right, a summary table is displayed, which includes the heat in and out by conduction and radiation, as well as the heat applied to node/group i. The sum in and sum out are also displayed, giving an idea of how balanced node/group i is. These values are based on the displayed values, so if the user has entered a Min Heat greater than 0.0, some energy is not be included in these sums. Note that energy storage/release is not included, as the difference between output timesteps is generally much larger than the calculation timesteps used and may not be a good indicator of instantaneous energy storage/release.

11.3 Dynamic Groups

The DynamicGroups option allows a user to expand some groups to detailed levels, while leaving other groups collapsed to simplistic representations. This can be very useful for investigating detailed heat flows in a specific portion of the model, without the need for detail throughout the model. To change the DynamicGroups setting, the user should double click the DynGroup cell on the NodeInfo sheet. A group tree is shown similar to the one below. Only groups shown in the tree are considered “active”. For the case below, the Panels MajorGroup is expanded to include the Inner and Outer Minor groups, the Elec MajorGroup is expanded to include the Lower, Mid, and Upper MinorGroups, but the Bat_Assy is collapsed to a single MajorGroup, even though it does have child groups defined under it. After the user closes the Dynamic Groups form, the heat flows are recalculated appropriately and output to the HeatMap.

11.4 Group to Group Heat Flow Matrix

A macro named MakeGroupToGroupMatrix can be run to generate worksheets that display the heat flow between groups in a matrix format as shown below. This macro creates four worksheets: MajorGroup, MinorGroup, SubGroup, and DynGroup based on the current timestep, Stefan-Boltzmann constant, and offset to absolute temperature. If any of these values are changed, then the macro must be rerun to generate updated data. The user can display: Tot Heat, Lin Heat, Rad Heat, Lin Cond, or Rad Cond by selecting the desired option from the drop down list in Cell A1.

11.5 Compare HeatMaps

The CompareHeatMaps option allows the user to specify two separate models for the generation of HeatMaps: Model A and Model B. Using the Map2 worksheet, results from two models can be displayed side by side. This can also be used to display different Node i or Timestep values for a single model HeatMap. Each side has independent controls for Sigma, Toffset, Format, Min Heat, and Heat To parameters. It also displays independent summaries.

To compare differences between heat flows the user should turn on the Compare option by running the CompareON macro. This signals to the heatmap that it should try to sequence the two sides. When the either Node I is changed in this mode, the change is update to the other. The data is then output and sequenced with a line containing heat paths of the same type (Lin, Rad), Node, and Conductance. In cases where a conductor may exist in one model but not in the other, the output attempts to synchronize the two sets of outputs matching the closest conductance value found for the same node and conductor type. If no match can be made, then a blank line is output where the heat path is missing from the other model. This can be useful when comparing two models that do not necessarily include the same environments (e.g. flight vs. TV test).


Sessions

12. Session Files

Session files are a means to save and recall properties of a TARP session. This can save the user time, if the same objects are to be created with only a few modifications. The formats for each object are shown below. In general, each object begins with a [Section] and ends with a blank line. Any object properties not specified are set to their default values; as such, only portions of the object need be defined.

12.1 Session File Data Types

Generic data types are listed below. Object types specific to particular objects are specified in the section for that object.

{Boolean} either True or False should be specified

{File Path} the full path including drive letter must be specified (spaces are allowed)

{XXX|YYY|ZZZ} one of XXX, YYY, OR ZZZ are allowed as inputs (single)

{XXX,YYY,ZZZ} any of XXX, YYY, OR ZZZ are allowed as inputs (multiple)

{Valid String} a sequence of alpha-numeric characters

{Valid Integer} a numeric entry (e.g.15)

{Valid Sheet} a {Valid String} that does not contain / \ [ ] ? or *

12.2 WorkBook Properties

Only one WorkBook Properties block may exist in a session. The WorkBook Properties block is as follows:

[WorkBook Properties]

  IncDesc = {Boolean}

  HeatMap = {Boolean}

CompareHeatMap = {Boolean}

UpdateExisting = {Boolean}

12.3 Additional Files

Only one Additional Files block may exist in a session. The Additional Files block is as follows:

[Additional Files]

  InputFile = {File Path}

  LimitFile = {File Path}

UnitConversionFile = {File Path}

ExcelOutputFile = {File Path}

12.4 DataSet

Numerous DataSet blocks may exist in a session file. A DataSet is defined as follows:

[DataSet]

  File = {File Path}

  Format = {SINDA85|SINDA/G|ESABLK|ESATBL|TMG|TAK|CSV}

  Parameter = {T|Q|G|C}

  SheetName = {Valid Sheet}

  Convert Time From = {Valid Integer}

  Convert Time To = {Valid Integer}

  Convert Param1 From = {Valid Integer}

  Convert Param1 To = {Valid Integer}

  Convert Param2 From = {Valid Integer or -1}

  Convert Param2 To = {Valid Integer or -1}

  Transpose = {Boolean}

  Filter = {Boolean}

FilterCriteria = {Valid Criteria or blank}

ReferencedNodes = {Boolean}

  IncludeMin = {Boolean}

  IncludeAvg = {Boolean}

  IncludeMax = {Boolean}

IncludeTimeMin = {Boolean}

IncludeTimeMax = {Boolean}

  IncludeDelta = {Boolean}

  SS Timestep Index = {Valid Index or -1}

  TR Timestep Start Index = {Valid Index or -1}

  TR Timestep End Index = {Valid Index or -1}

  Output Timesteps = {Timestep Output}

DataSet Data Types:

{Valid Criteria} a special version of {Valid String} based on the rules for node filtering

{Valid Index} a special version of {Valid Integer} that requires an index to a particular array (e.g. timesteps)

{Timestep Output} a string listing of T or F indicating for each timestep if it is to be output. (e.g. TTFFTTFT would output timesteps 1,2,5, 6, and 8)

12.5 Plot

Numerous Plot blocks may exist in a session file. A Plot is defined as follows:

[Plot]

  Title={Valid String}

  SheetName={Valid Sheet}

  X Axis={Axis String}

  Y Axis Pri={Axis String}

  Y Axis Sec={Axis String}

  Series={SheetName}/{Data}/{Pri|Sec}

    Line={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

...

  Series={SheetName},{Data},{Pri|Sec}

    Line={Color},{LineType},{Weight}

    Marker={Symbol},{Color},{Color},{Size},{Freq},{Shadow|NoShadow}

** Note that the Series are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

Plot Data Types:

{Axis String} AxisMin or -100000 for Default, AxisMax or 100000 for Default, MajorDivision, MinorDivision (e.g. -100000,100000,5,1)

{SheetName} String value representing a valid DataSet

{Data} String value representing a valid Node or Group in the {SheetName} DataSet

{Size} Integer value for marker size

{Freq} Integer value for marker frequency

{LineType} any entry in the table below

Solid | Dashed | Dotted | Dash-Dot | Dash-Dot-Dot | Med Density
High Density | Low Density |  |  |  |

{Color} any entry in the table below

Default | None | Black | White | Red | DarkRed
Blue | DarkBlue | LightBlue | BlueGray | OceanBlue | SkyBlue
Yellow | DarkYellow | LightYellow | Gold | PaleBlue | IceBlue
Green | DarkGreen | LightGreen | BrightGreen | OliveGreen | SeaGreen
Turquoise | LightTurquoise | Aqua | Violet | DarkPurple | Lime
Teal | DarkTeal | Indigo | Periwinkle | Rose | Lavender
Orange | LightOrange | Brown | Tan | Coral | Pink
Gray25 | Gray40 | Gray50 | Ivory | Plum |

{Weight} any entry in the table below

Hairline

Thin

Medium

Thick

{Symbol} any entry in the table below

None | Square | Diamond | Triangle | X | Star
Dot | Dash | Circle | Plus |  |

12.6 Table

Numerous Table blocks may exist in a session file. A Table is defined as follows:

[Table]

  SheetName= {Valid Sheet}

  Nodes= {Data1},{Data2},{Data3},...,{DataN}

  SourceSheet= {SheetName1}/{SheetName2}/.../{SheetNameM}

  Parameter= {Parameter1},{Parameter2},...,{ParameterM}

  Conditional 1= {Condition1},{Condition2},...,{ConditionM}

  Conditional 2= {Condition1},{Condition2},...,{ConditionM}

  Conditional 3= {Condition1},{Condition2},...,{ConditionM}

  Options= {BoldConditionals,SheetsOnTop,FormatBorders,RepeatHeaders}

** Note that the sheet names are delimited by “/”. This is to allow a comma in a SheetName which would be interpreted as a delimiter if a “,” were used instead of a “/”.

Table Data Types:

{SheetName#} the sheet name for a particular DataSet

{Data#} valid Node or Group from a DataSet

{Parameter#} Table parameter (e.g. Min, Max, etc.)

{Condition#} {<|<=|>=|>}LimitName+{Margin}={ForeColorIndex},{BackColorIndex} or leave blank (see Conditional Formatting section)

{ColorIndex} any numeric entry in the table below

1 | Black | 2 | White | 3 | Red | 4 | BrightGreen | 5 | Blue
6 | Yellow | 7 | Pink | 8 | Turquoise | 9 | DarkRed | 10 | Green
11 | DarkBlue | 12 | DarkYellow | 13 | Violet | 14 | Teal | 15 | Gray25
16 | Gray50 | 17 | Periwinkle | 18 | Plum | 19 | Ivory | 20 | LightTurquoise
21 | DarkPurple | 22 | Coral | 23 | OceanBlue | 24 | IceBlue | 25 | DarkBlue
26 | Pink | 27 | Yellow | 28 | Turquoise | 29 | Violet | 30 | DarkRed
31 | Teal | 32 | Blue | 33 | SkyBlue | 34 | LightTurquoise | 35 | LightGreen
36 | LightYellow | 37 | PaleBlue | 38 | Rose | 39 | Lavender | 40 | Tan
41 | LightBlue | 42 | Aqua | 43 | Lime | 44 | Gold | 45 | LightOrange
46 | Orange | 47 | BlueGray | 48 | Gray40 | 49 | DarkTeal | 50 | SeaGreen
51 | DarkGreen | 52 | OliveGreen | 53 | Brown | 54 | Plum | 55 | Indigo
56 | DarkBlue |  |  |  |  |  |  |  |

12.7 Group

Numerous Group blocks may exist in a session file. A Group is defined as follows:

[Group]

  GroupName= {Group Name}

  ParentName= {Group Name}

  Nodes= {Node1},{Node2},{Node3},...,{NodeN}

Group Data Types:

{Group Name} a {Valid String} that does not contain any comma characters (,)

{Node#} valid Node on DataSet sheets

12.8 Parameter

Numerous Parameter blocks may exist in a session file. A Parameter is defined as follows:

[Parameter]

ParameterName= {Valid String}

  ParameterType= {MaxNodes|MinNodes|MaxGroup|MinGroup|Difference}

  Nodes= {Node1},{Node2},{Node3},...,{NodeN}


Creatng the Workbook

13. Creating the WorkBook

Once all objects and their properties are defined, the user clicks the Make XL button at the main interface to begin creating the Excel® workbook. During each step, progress is indicated in a progress bar for the subtask currently being processed. The program begins by processing the input file (if Node Descriptions were requested). Next, it reads the input files for each DataSet and outputs the data to the specified worksheets. Then the NodeInfo sheet is created, merging node descriptions, groups definitions, and limits onto a single worksheet. The group and parameter definitions are then appended to each DataSet worksheet as well as any Minimum, Average, Maximum formulas. All Plots are created next, followed by all Tables. Lastly, if HeatMaps are being generated, the Lin and Rad conductor sheets are created. Finally, the workbook is saved and the final workbook is opened in Excel® for examination by the user.

Back to Session Files


- 24 -